Overview

Help > Overview
Overview

This chapter presents the information how to use this manual and quick start if you are already familiar with Microsoft Visual Studio and C# programming language.

© 2021 JYTEK company. All rights reserved.


Introduction

Help > Overview > Introduction
Introduction

JYTEK PCIe/PXIe-6302 is a high-resolution temperature measurement module which provides up to 32 channels, supports R/S/B/J/T/E/K/N/C/A type thermocouple, with input voltage range of -78.125 mV ~ +78.125 mV and sample rate up to 800 Samples/sec.

With 24 Bits ADC chip and analog-to-digital conversion mechanism optimized for voltage measurement, the PCIe/PXIe-6302 has an optimum voltage measurement offset error of up to 1µV and a voltage measurement gain error of 2 ppm.

PCIe/PXIe-6302 has a very low temperature drift, with a typical bias error temperature drift of 10 nV/°C and a maximum offset error temperature drift of 0.1 µV/°C.


Main Features

Help > Overview > Main Features
Main Features

l 32 channels of thermocouple measurements

l 3 voltage ranges:±78.125 mV / ±39.06 mV / ±19.53 mV

l Support R/S/B/J/T/E/K/N/C/A type thermocouple

l 8 cold-junction compensation channels provided by 2 TB-68CJ terminal boxes

l Onboard 128M sample FIFO buffer for analog input

l DMA for analog input

l 24 bits resolution

l Provide EMF temperature measurement value

l Digital and Software Trigger


Abbreviations

Help > Overview > Abbreviations
Abbreviations

AI: Analog Input

ADC: Analog to Digital Conversion

PFI: Programmable Function Interface

CJ: Cold-Junction

CJC: Cold-Juntion Compensation

OTD: Open Thermocouple Detection


1.4 Learn by Example

Help > Overview > 1.4 Learn by Example
1.4 Learn by Example

JYTEK has added Learn by Example in this manual. We provide many sample programs for this device. You can download a JYPEDIA excel file from our web www.jytek.com. Open JYPEDIA and search for JY6302 in the driver sheet, select JY6302_Examples.zip. This will lead you to download the sample program for this device. In addition to the download information, JYPEDIA also has a lot of other valuable information, JYTEK highly recommends you use this file to obtain information from JYTEK.

Figure 1 JYPEDIA Information

In a Learn by Example section, the sample program is in bold style such asWinform AI Continuous; the property name in the sample program is also in bold style such as SamplesToAcquire; the technical names used in the manual is in italic style such as SampleRate. You can easily relate the property names in the example program with the manual documentation.

In a Learn by Example section, the experiment is set up as follow. A PCIe/PXIe- 6302 card is plugged in a desktop computer. The PCIe/PXIe-6302 is connected to a TB- 68CJ terminal block.

Figure 2 TB- 68CJ terminal block.

The TB-68CJ has 4 terminal columns, J1 – J4 are shown below as Figure 3 . In the rest of this manual, the wire connection in each Learn by Example section will be given by the pin numbers only.

Figure 3 TB-68CJ Pin Define


Hardware Specifications

Help > Hardware Specifications
Hardware Specifications

The 6302 is one of the family of temperature data acquisition module which provides different interfaces, such as PCIe, PXIe, TXI(Thuderbolt) and USB buses (coming soon). 6302 on different interfaces is shown in Table 1.

Table 1 63xx on different buses


System Diagram

Help > Hardware Specifications > System Diagram
System Diagram

Figure 4 6302 System Block Diagram

Figure 4 shows the system diagram of the 6302. The system is mainly composed of ADC, DDR and FPGA control modules. The FPGA-based driver code provides a stable and efficient PCIe / PXIe / USB interface. 6302 has four ADCs, which can work alone or together depending on channel configuration. Each ADC is responsible for the measurement of one group of 8 channels and selects one of the 8 channels through the multiplexer at the falling edge of AD conversion clock, as shown in Figure 22.

The channel grouping is shown in Table 2.

Table 2 6302 channel grouping

6302’s dedicated terminal block TB-68CJ has build-in temperature sensors for measuring cold-juntion temperature to achieve cold-junction compensation (CJC).

* The terms "hot junction" and "cold junction" are used in this manual, which also called "measuring junction" and "reference junction".


Sensor Connection

Help > Hardware Specifications > Sensor Connection
Sensor Connection

Figure 5 Themocouple connection


Input Characteristics

Help > Hardware Specifications > Specification > Input Characteristics
Input Characteristics

Table 3 Input Characteristics


Timing and Trigger

Help > Hardware Specifications > Specification > Timing and Trigger
Timing and Trigger

Table 4 Timing and Trigger Specification


Physical and Environment

Help > Hardware Specifications > Specification > Physical and Environment
Physical and Environment

Table 5 Physical and Environment


Front Panel conections and Pinout Definition

Help > Hardware Specifications > Front Panel conections and Pinout Definition
Front Panel conections and Pinout Definition

Figure 6 PXIe/PCIe 6302 Front Panel

PCIe/PXIe-6302 provides 32 channels of thermocouple measurements and 4 digital input channels (for digital triggering).

Table 6 Pinout defination


Voltage Accuracy

Help > Performance Test > Voltage Accuracy
Voltage Accuracy

Table 7 Voltage Accuracy

Figure 7 Typical Error (30mV Input)

Figure 8 Typical Error (65mV Input)

Table 8 Input noise

Figure 9 Typical Noise (Level 0)

Figure 10 Typical Noise (Level 1)

Figure 11 Typical Noise (Level 2)

Figure 12 Typical Noise (Level 3)

Figure 13 Typical Noise (Level 4)

Figure 14 Typical Noise (Level 5)

Table 9 Input Stability

Figure 15 Typical Drift (30mV Input)

Figure 16 Typical Drift (60mV Input)


Temperature Accuracy

Help > Performance Test > Temperature Accuracy
Temperature Accuracy

Temperature Accuracy

Table 10 Temperature Accuracy

Measurement sensitivity

Table 11 Measurement sensitivity


System Requirements

Help > Software > System Requirements
System Requirements

PCIe/PXIe-6302 modules can be used in a Windows or a Linux operating system.

Microsoft Windows: Windows 7 32/64 bit, Windows 10 32/64 bit.

Linux Kernel Versions: There are many Linux versions. It is not possible JYTEK can support and test our devices under all different Linux versions. JYTEK will at the best support the following Linux versions.

Table 12 Supported Linux Versions


System Software

Help > Software > System Software
System Software

When using the PCIe/PXIe-6302 in the Window enviornment, you need to install the following software from Microsoft:

Visual Studio Version 2015 or above,

.NET version is 4.0 or above.

.NET is coming with Windows 10. For Windows 7, please check .NET verson and upgrade to 4.0 or later version.

Given the resouces limitation, JYTEK only tested 6302 modules with .NET 4.0 with Visual Studio 2015. JYTEK relies on Microsoft to maintain the compatibility for the newer versions.


C# Programming Language

Help > Software > C# Programming Language
C# Programming Language

All JYTEK defaut programming language is Microsoft C#. This is Microsoft recommended programming language in Visual Studio and is particularly suitable for the test and measurement applications. C# is also a cross platform programming language.


6302 Hardware Driver

Help > Software > 6302 Hardware Driver
6302 Hardware Driver

After installing the required application development environment as described above, you need to install the 6302 hardware driver.

JYTEK hardware driver has two parts: the shared common driver kernel software (FirmDrive) and the hardware specific driver software.

Common Driver Kernel Software (FirmDrive): FirmDrive is the JYTEK’s kernel software for all hardware products of JYTEK instruments. You need to install this kernel software before using any other JYTEK hardware products. FirmDrive only needs to be installed once. After that, you can install the hardware specific driver.

Hardware Specific Driver: Each JYTEK hardware has a C# hardware specific driver. This driver provides rich and easy-to-use C# interfaces for users to operate various 6302 function. JYTEK has standardized the ways JYTEK and other vendor’s DAQ cards are used by providing a consistant user interface, using the methods, properties and enumerations in the object-oriented programming enviornment. Once you get yourself familiar with how one JYTEK DAQ card works, you shoud be albe to know how to use all other DAQ hardware using the same methods.


Install the SeeSharpTools from JYTEK

Help > Software > Install the SeeSharpTools from JYTEK
Install the SeeSharpTools from JYTEK

To efficiently and effectively use 6302 boards, you need to install a set of free C# utilities from JYTEK SeeSharp Test and Measurement platform. The SeeSharp platform offers rich user interface functions you will find convenient in developing your applications. They are also needed to run the examples come with 6302 hardware. Please register and down load the latest SeeSharpTools from our website www.jytek.com.


Running C# Programs in Linux

Help > Software > Running C# Programs in Linux
Running C# Programs in Linux

Most C# written programs in Windows can be run by Microsoft Mono development system in a Linux enviornment. You would develop your C# applications in Windows using Visual Stuido. Once it is done, run this application in the Mono environment. This is JYTEK recommended way to run your C# programs in a Linux environment.

If you want to use your own Linux development system other than Mono, you can do it using our Linux driver. However, JYTEK does not have the capability to support the Linux applications. JYTEK completely relies upon Microsoft to maintain the cross-platform compatibility between Windows and Linux using Mono.


Operating 6302 Module

Help > Operating 6302 Module
Operating 6302 Module

This chapter provides the operation guides for 6302, including thermocouple input and programmable I/O interface, etc.

JYTEK provides extensive examples, on-line help and documentation to assist you to operate the 6302 module. JYTEK strongly recommends you go through these examples before writing your own application. In many cases, an example can also be a good starting point for a user application.


Quick Start

Help > Operating 6302 Module > Quick Start
Quick Start

After you have installed the driver software and the SeeSharpTools, you are ready to use Visual Stuidio and our C# measurement and control platform tools (SeeSharp Platform) to operate the 6302 products.

If you are already familiar with Microsoft Visual Studio and C# programming, the quickest way to use 6302 cards is to go through our extensive examples. We provide source code of our examples. In many cases, you can modify the source code and start to write your applications.


AI Operations

Help > Operating 6302 Module > AI Operations
AI Operations

When performing AI operations, it will be helpful if you understand the characteristics of the signal to be acquired, then configure 6302 accordingly. Once configured, you can use our tools to read data and save it in the memory or on a disk for your future analysis. Please see the provided software examples for more information.


Channel Scan Sequence

Help > Operating 6302 Module > AI Operations > Channel Scan Sequence
Channel Scan Sequence

The scanning order of the channels is related to the order in which the user adds channels. When the acquisition task starts, the channels added by the user will be assigned to each ADC according to the group to which they belong. Each ADC will automatically switch channels through the multiplexer to traverse all the enabled channels of the ADC for A/D conversion.

For a single ADC, the scan order is always consistent with the order in which the channels within the ADC grouping are added. However, since the four ADCs work at the same time, the scanning order of all channels does not necessarily coincide with the order in which the user adds channels.

Figure 17 shows a typical channel scan sequence. In this case, the user adds all channels (Ch0~Ch31) in sequence, and these channels are automatically assigned to four ADCs. At the beginning of the acquisition task, each ADC will start working at the same time, converting the channels in its group in turn.

Figure 17 Typical channel scan sequence

Figure 18 shows a random channel scan sequence, in which case the user added some channels in random order.

Figure 18 Random channel scan sequence

When using the driver, although the scan order of the channels does not necessarily match the order of adding channels, the data is automatically reordered internally by the driver, so the order of the data of each channel’s reading data will always be the same as the order of added channels.


ADC Timing Modes

Help > Operating 6302 Module > AI Operations > ADC Timing Modes
ADC Timing Modes

The ADC inside 6302 has a built-in digital filter and multiple filter options. Filter options affect the data output rate and 50 Hz / 60 Hz rejection, and the lower the data output rate, the better the noise rejection.

The 6302 driver provides a total of 6 output data rates, from Level 0 to Level 5. Level 0 has the slowest data output rate and best noise rejection. Level 5 has the fastest data output rate and worst noise suppression performance.

The reciprocal of the output data rate is the time required for each A /D conversion. Table 13 describes the A /D conversion time for each data rate.

Table 13 A/D conversion time at different speed levels

In the default configuration, the rate level is set to Auto. The drive will automatically select the lowest rate level which is according to the sampling rate and the number of added channels.

If the user explicitly specifies the rate level, the driver will automatically limit the highest sampling rate according to the number of added channels and the specific rate level. If the user-setsampling rate exceeds the limit, the driver will automatically revise it.

For a more detailed description of the relationship between Timing Modes and sample rates, please refer to Section 5.2.3.


Learn by Example 5.2.2

Help > Operating 6302 Module > AI Operations > ADC Timing Modes > Learn by Example 5.2.2
Learn by Example 5.2.2

n Connect the K-type Thermocouple’s positive pole and negative pole to Terminal Block’s TCO+ (Pin#35) and TCO- (Pin#1);

n Open Winform AI Continuous Raw Data, Choose Auto in Timing mode. Set the other parameters as shown;

Figure 19 AI Continuous Raw Data Paraments

n Click Start. The result is shown below.

Figure 20 Continuous Raw Data Acquisition

n Now change the mode of Timing Mode to Level5 and click Start. A message will appear in the lower left corner as shown.

Figure 21 Acquisition State

Ø Choosing different modes in Timing Mode will have the corresponding conversion rate.


Sampling Rate

Help > Operating 6302 Module > AI Operations > Sampling Rate
Sampling Rate

When 6302 works, each sample contains the completion of an A/D conversion on all channels, the principle is shown in Figure 22.

Figure 22 A/D conversion and sampling

The timing required for each A /D conversion is controlled by setting rate level. The minimum sampling rate of PCIe/PXIe-6302 is 0.275 Samples/s, and the highest sampling rate is 800 Samples/s. The actual maximum sampling rate is according to the rate level and the number of channels added by each ADC:

Among them:

l [image] : The maximum sample rate that can be set

l [image] : Maximum number of channels added on a single ADC

l [image] : The maximum total sampling rate at the current rate level, as shown in Table 14.

Table 14 ADC Timing Modes and maximum aggregate sampling rate

When the user sets the timing mode to Auto, the driver internally reverses the current actual total sample rate according to the following formula:

Among them:

l [image] : Current actual total sampling rate

l [image] : Maximum number of channels added on a single ADC

l [image] :: User-set sampling rate

After the drive internally finds the actual total sampling rate, the lowest timing mode is automatically selected according to the interval divided in above Table 14.


Cold-junction compensation

Help > Operating 6302 Module > Cold-junction compensation
Cold-junction compensation

6302 is equipped with a dedicated terminal block TB-68CJ, and two TB-68CJ terminal boxes provide a total of 8 cold-junction temperature measurement.

There are four temperature sensors evenly distributed on each TB-68CJ, and each temperature sensor is responsible for the cold-junction temperature measurement of the four channels adjacent to it.

When the user starts a task, the PCIe/PXIe-6302 will simultaneously scan the cold-junction temperature and store the data in the onboard memory. When the user reads the data, the PCIe/PXIe-6302 driver will automatically pair the measurement channel data with the cold-junction channel data for cold-junction compensation.

Terminal block connection automatic detection

6302’s pins include the power and communication interface of the TB-68CJ. The software driver can check whether the TB-68CJ is properly connected.

When the acquisition task is started, the driver will automatically confirm whether the TB-68CJ on the two connectors are connected reliably. If the TB-68CJ is detected as not connected, but the channel belonging to the terminal block is added, the task is not allowed to start and an exception will be thrown.

Customized cold-junction temperature

The PCIe/PXIe-6302 driver allows the user to customize the cold junction temperature for each channel. To use this function, you should disable the build-in cold-junction compensation (set the property BuildInCJCEnabled to False) before start the task, and call the function SetRJTemperature to set the cold-junction temperature after starting the task and before reading the data.

Unlike the build-in CJC, this customized cold-junction temperature data is not synchronized with the hot-junction temperature data, but takes effect every time the ReadData function is called.


Learn by Example 5.3

Help > Operating 6302 Module > Cold-junction compensation > Learn by Example 5.3
Learn by Example 5.3

n Connect the K-type Thermocouple’s positive pole and negative pole to Terminal Block’s TCO+ (Pin#35) and TCO- (Pin#1);


Terminal block connection automatic detection

Help > Operating 6302 Module > Cold-junction compensation > Learn by Example 5.3 > Terminal block connection automatic detection
Terminal block connection automatic detection

n Open Winform Terminal Block State;

n Set other parameters as shown and click Connect, the result is shown below.

Figure 23 Terminal Block State Check

Ø Connectors show the working state of the Terminal Block.


Open thermocouple detection

Help > Operating 6302 Module > Open thermocouple detection
Open thermocouple detection

The thermocouple open circuit detection function is provided in the driver to help the user detect the connection status of the thermocouple.

When the user calls the method PerformOpenThermocoupleDetection, the PCIe/PXIe-6302 outputs 0.5 µA/ 2 µA/ 4 µA (software configurable) excitation current on all TC+ terminals, traversing each enabled channel for voltage acquisition. This method returns a Dictionary that represents the open-circuit detection results for each channel.


Learn by Example 5.4

Help > Operating 6302 Module > Open thermocouple detection > Learn by Example 5.4
Learn by Example 5.4

n Connect the K-type Thermocouple’s positive pole and negative pole to Terminal Block’s TCO+ (Pin#35) and TCO- (Pin#1);

n Open Winform Open Thermocouple Detection;

n Choose Channels in Channel ID.

n Set other numbers as shown and click Detect, the result is shown below.

Figure 24 Open Thermocouple Detection

Ø Status indicates the current working state of the channel.


Immediate Trigger

Help > Operating 6302 Module > Trigger Source > Immediate Trigger
Immediate Trigger

The module will acquire the signal immediately after executing the acquisition without any trigger condition setting by default.


Software Trigger

Help > Operating 6302 Module > Trigger Source > Software Trigger
Software Trigger

The anglog acquisition task will wait in the software trigger mode until receiving a software trigger signal from driver, then will start to acquire the data.


External Digital Trigger

Help > Operating 6302 Module > Trigger Source > External Digital Trigger
External Digital Trigger

The module supports different external digital trigger sources from PXI Trigger bus (PXI_TRIG<0..7>), PXI_STAR and connectors of front panel (PFI). The high pulse width of digital trigger signal must be longer then 20 ns for effective trigger. The module will monitor the signal on digital trigger source and wait for the rising edge or falling edge of digital signal which depends on the set trigger condition, then causes the module to acquire the data as shown in Figure 25 below:

Figure 25 Rising and falling edges of digital signals


Learn by Example 5.5.3

Help > Operating 6302 Module > Trigger Source > External Digital Trigger > Learn by Example 5.5.3
Learn by Example 5.5.3

n Connect the K-type Thermocouple’s positive pole and negative pole to Terminal Block’s TCO+ (Pin#35) and TCO- (Pin#1), then connect the signal source’s positive pole and negative pole to PCIe/PXIe-6302 PFI0 (Pin#64) and GND (Pin#30);

n Set the signal source Ch1’s output to square wave (f=1Hz, Vpp=5v);

n Open Winform AI Finite Digital Trigger;

n Choose Rising in Trigger Condition and choose PFI_0 in Trigger Source;

n Set other numbers as shown and click Start.

Figure 26 Digital Trigger Paraments

Ø Trigger Source must match the pin on the terminal block.

Ø There are two Trigger Conditions: Rising and Falling.

n The result shows below:

Figure 27 Digital Trigger Acquisition

Ø Since the squarewave is used for the digital trigger source, when a rising edge of the squarewave occurs, the digital trigger will be activated, and the data acquisition will start.


Trigger Mode

Help > Operating 6302 Module > Trigger Mode
Trigger Mode

The analog inputs of the 6302 support several trigger modes: Start Trigger, Reference Trigger and Retrigger.


Start Trigger

Help > Operating 6302 Module > Trigger Mode > Start Trigger
Start Trigger

In this mode, the analog acquisition task will start to acquire the signal immediately after the trigger asserted as shown in Figure 28. The Start Trigger mode is suitable for continuous acquisition and finite acquisition mode.

Figure 28 Start Trigger mode


Learn by Example 5.6.1

Help > Operating 6302 Module > Trigger Mode > Start Trigger > Learn by Example 5.6.1
Learn by Example 5.6.1

n Connect the K-type Thermocouple’s positive pole and negative pole to Terminal Block’s TCO+ (Pin#35) and TCO- (Pin#1);

n Open Winform AI Continuous, set the following numbers as shown;

Figure 29 AI Continuous Paraments

n When Start is clicked, it generates a start trigger, which starts the acquisition. The result is shown below.

Figure 30 Signel Channel Continuous Acquisition


Reference Trigger

Help > Operating 6302 Module > Trigger Mode > Reference Trigger
Reference Trigger

User can configure a trigger condition and acquire the data between trigger asserted in the Reference Trigger mode. Data acquired before trigger occurred is pretrigger samples. Data acquired after trigger occurred is posttrigger samples. User can configure two parameters, “PretriggerSamples” and “SamplesToAcquire” to capture specified data as shown in Figure 31.

This trigger mode is only suitable for finite acquisition mode. The default number of pretrigger samples is 0.

l SampleToAcquire: 1000

l PreTriggerSamples: 10

l Posttrigger samples: 1000 - 10 = 990

Figure 31 Reference Trigger mode


Retrigger

Help > Operating 6302 Module > Trigger Mode > Retrigger
Retrigger

User can configure a specified trigger condition and repeat trigger times to capture signal. The number of repeat trigger times is set by the parameter “ReTriggerCount”. For example, we set the ReTriggerCount to N and the length of each acquisition to M, therefore the total acquired samples is N * M * channelcounts as shown in Figure 32.

Note, Retrigger mode is only valid in finite acquisition mode.

When the retriggering number is set to - 1, it will wait on trigger infinitely until aborting the task.

Figure 32 Retrigger mode


Learn by Example 5.6.2 and 5.6.3

Help > Operating 6302 Module > Trigger Mode > Learn by Example 5.6.2 and 5.6.3
Learn by Example 5.6.2 and 5.6.3

n Connect the K-type Thermocouple’s positive pole and negative pole to Terminal Block’s TCO+ (Pin#35) and TCO- (Pin#1), then connect the signal source’s positive pole and negative pole to PCIe/PXIe-6302 PFI 1 (Pin#65) and GND (Pin#31);

n Set the signal source Ch1’s output to sinewave signal (f=4Hz, Vpp=5v).

n Open Winform AI Finite Digital Trigger, set the following numbers as shown.

Figure 33 Retrigger Paraments

Ø You can use three different kinds of triggers in this program as mentioned in this chapter. Start Trigger and Reference Trigger can be set by Trigger Mode. For Re-Trigger it can be used by changing the numbers in Retrigger Count.

n Now the Trigger Mode is “Reference”, and the PreTrigger Samples are 10. Click Start to begin the data acquisition, the result is shown below:

Figure 34 Retrigger In Reference Trigger Mode

Ø Because the measured waveform is an irregular continuous line, the effect of Trigger mode change can not be seen clearly.

n Now change the mode of trigger to Retrigger through giving Retrigger Count the number 3 and click Start. A message will appear in the lower left corner: “Samples acquired: 200/300”.

Figure 35 Retrigger Complete State

Ø It shows the acquisition process through every trigger signal.


System Synchronization Interface（SSI）for PCIe Modules

Help > Operating 6302 Module > System Synchronization Interface（SSI）for PCIe Modules
System Synchronization Interface（SSI）for PCIe Modules

The synchronization between PCIe modules are handled differently from the PXIe synchronization, it is implemented by the system synchronization interface (SSI). SSI is designed as a bidirectional bus and it can synchronize up to four PCIe modules. One PCIe module is designated as the master module and the other PCIe modules are designated as the slave modules.

Figure 36 SSI Connector in PCIe-6302

Table 15 SSI Connector Pin Assignment for PCIe-6302


DIP Switch in PCIe-6302

Help > Operating 6302 Module > DIP Switch in PCIe-6302
DIP Switch in PCIe-6302

PCIe-6302 series Module has a DIP switch. The card number can be adjusted manually by changing the DIP switch setting, which is used to identify the boards with different slot position.

For example, if you want to set the card number to 3, you could turn the position 2 and 1 of the DIP switch to the ON position and the orthers to OFF. Find the detail below.

Figure 37 DIP Switch in PCIe-6302

Table 16 Relationship between switch position and slot number


Calibration

Help > Calibration
Calibration

JYTEK 6302 boards are precalibrated before the shipment. We recommend you recalibrate 6302 board periodically to ensure the measurement accuracy. A commonly accepted practice is one year. If you need to recalibrate your board, please contact JYTEK.


Using 6302 in Other Software

Help > Using 6302 in Other Software
Using 6302 in Other Software

While JYTEK’s default application platform is Visual Studio, the programming language is C#, we recognize there are other platforms that are either becoming very popular or have been widely used in the data acquisition applications. Among them are Python, C++. This chapter explains how you can use 6302 DAQ card using one of this software.


Python

Help > Using 6302 in Other Software > Python
Python

JYTEK provides and supports a native python driver for 6302 cards. There are many different versions of Python. JYTEK has only tested in CPython version 3.5. There is no guarantee that JYTEK python drivers will work correctly with other versions of Python.

If you want to be our paNEGer to support different Python platforms, please contact us.


C++

Help > Using 6302 in Other Software > C++
C++

JYTEK internaly uses our C++ drivers to design the C# drivers. We recommend our customers to use C# drivers because C# platform deliver much better efficiency and performance in most situations. We also make our C++ drivers available. However, due to the limit of our resources, we do not actively support C++ drivers. You can down load our C++ drivers from JYTEK’s website. We welcome you report the bugs in our C++ drivers, but will not be able to guarantee that we can fix it within your expectation.

If you want to be our paNEGer to support C++ drivers, please contact us.


JYTEK China

Help > About JYTEK > JYTEK China
JYTEK China

Founded in June 2016, JYTEK China is a leading Chinese test & measurement company, providing complete software and hardware products for the test and measurement industry. The company is a joint venture between Adlink Technologies and a group of experienced professionals form the industry. JYTEK independenly develop the software and hardware products and is entirely focused on the Chinese market. Our Shanghai headquarters and production service center have regular stocks to ensure timely supply; we have R&D centers in Xi'an and Chongqing to develop new products; we also have highly trained direct technical sales representatives in Shanghai, Beijing, Tianjin, Xi'an, Chengdu, Nanjing, Wuhan, Haerbin, and Changchun. We also have many patners who provide system level support in various cities.


JYTEK Korea and JYTEK in Other Countries

Help > About JYTEK > JYTEK Korea and JYTEK in Other Countries
JYTEK Korea and JYTEK in Other Countries

JYTEK Korea was the first JYTEK enterprise outside China to promote JYTEK products. Together with Adlink Technologies and JYTEK China, JYTEK is expanding to other countries. Each JYTEK location is an independently owned and operated franchise. It shares JYTEK’s philosophy and business approach. Together JYTEK entities promote the JYTEK brand, technology, and products.


JYTEK Hardware Products

Help > About JYTEK > JYTEK Hardware Products
JYTEK Hardware Products

According to JYTEK’s agreement with our equity paNEGer Adlink Technologies, JYTEK’s hardware is manufactured by the state-of-art manufacturing facility located in Shanghai Zhangjiang Hi-Tech Park. Adlink has over 20 years of the world-class low-volumn and high-mix manufacturing expertise with ISO9001-2008, China 3C, UL, ROHS, TL9000, ISO-14001, ISO-13485 certifications. Its 30,000 square meters facilities and three high-speed Panasonic SMT production lines can produce 60,000 pieces boards/month; it also has full supply chain management - planning, sweeping, purchasing, warehousing and distribution. Adlink’s manufacturing excellence ensures JYTEK’s hardware has word-class manufacturing quality.

One core technical advantage is JYTEK’s pursue for the basic and fundamental technology excellence. JYTEK China has developed a unique PCIe, PXIe, USB hardware driver architecture, FirmDrive, upon which many our future hardware will be based.

In addition to our own developed hardware, JYTEK also rebrands Adlink’s PXI product lines. In addition, JYTEK has other rebranding agreements to increase our hardware coverage. It is our goal to provide the complete product coverage in PXI and PCI modular instrumentation and data acquisition.


JYTEK Software Platform

Help > About JYTEK > JYTEK Software Platform
JYTEK Software Platform

JYTEK has developed a complete software platform, SeeSharp Platform, for the test and measurement applications. We leverage the open sources communities to provide the software tools. Our platform software is also open sourced and is free, thus lowering the cost of tests for our customers. We are the only domestic vendor to offer complete commercial software and hardware tools.


JYTEK Warranty and SupportServices

Help > About JYTEK > JYTEK Warranty and SupportServices
JYTEK Warranty and SupportServices

With our complete software and hardware products, JYTEK is able to provide technical and sales services to wide range of applications and customers. In most cases, our products are backed by a 1-year warranty. For technical consultation, pre-sale and after-sales support, please contact JYTEK of your country.


Statement

Help > Statement
Statement

The hardware and software products described in this manual are provided by JYTEK China, or JYTEK in short.

This manual provides the product review, quick start, some driver interface explaination for PCIe/PXIe-6301 family of temperature sensor data acquisition cards. The manual is copyrighted by JYTEK.

No warranty is given as to any implied warranties, express or implied, including any purpose or non-infringement of intellectual property rights, unless such disclaimer is legally invalid. JYTEK is not responsible for any incidental or consequential damages related to performance or use of this manual. The information contained in this manual is subject to change without notice.

While we try to keep this manual up to date, there are factors beyond our control that may affect the accuracy of the manual. Please check the latest manual and product information from our website.

Shanghai Jianyi Technology Co., Ltd.

Address: Room 201, Building 3, NO.300 Fangchun Road, Shanghai.

Post Code：201203

Tel：021-5047 5899

Website：www.jytek.com